Frage Kann susy-2.1.1 nicht aktivieren, weil sass-3.2.17 mit sass kollidiert (~> 3.3.0)


Ich habe die neuesten Versionen von Kompass, Sass und Susy installiert. Aber immer noch bekomme ich diesen Fehler:

Unable to activate susy-2.1.1, because sass-3.2.17 conflicts with sass (~> 3.3.0)

Weiß jemand, wie diese Ruby-Sache funktioniert?

Dies ist die Liste meiner installierten Edelsteine:

*** LOCAL GEMS ***

CFPropertyList (2.2.0)
chunky_png (1.3.0)
compass (0.12.4)
compass-core (1.0.0.alpha.19)
compass-import-once (1.0.4)
compass-rails (1.1.3)
fssm (0.2.10)
libxml-ruby (2.6.0)
multi_json (1.9.2)
nokogiri (1.5.6)
rb-fsevent (0.9.4)
rubygems-update (2.2.2)
sass (3.3.4, 3.3.3, 3.2.17)
sqlite3 (1.3.7)
susy (2.1.1)

5
2018-03-22 10:03


Ursprung


Antworten:


Wenn Sie Bundler verwenden, wird sichergestellt, dass die Edelsteine ​​in Ihrer Gemfile diejenigen sind, die von Ihrem Projekt verwendet werden. Dein Gemfile sollte also "susy", "~> 2.1.1" und "sass", "~> 3.3.2" sowie alle anderen benötigten "Breakpoint", "~> 2.4.1" angeben. Es spielt dann keine Rolle, welche Versionen in Ihrem Ruby Gems-Ordner installiert sind. Wenn Sie dann eine Bundle-Installation durchführen, stellt Bundler sicher, dass Ihr Projekt nur die richtigen Abhängigkeiten verwendet. Dies ist natürlich ein CLI-Befehl durch das Terminal. Alternativ kannst du einfach 'sudo gem uninstall sass -v 3.2.17' ausführen, wenn du Bundler nicht benutzen willst.


4
2018-03-22 17:00



gem install compass --pre

Wenn du das Sass 3.3.0 Juwel deinstalliert hast, solltest du das zuerst installieren.


10
2018-03-22 14:31



Der beste Weg ist ohne Zweifel Susy über das Compass Susy Plugin zu installieren. Dies vermeidet Konflikte mit anderen Compass-Projekten, die die aktuelle Version benötigen.

Befehle:

gem install compass
gem install compass-susy-plugin

5
2018-05-22 00:19



Ich benutze Ubuntu Server 14.04 und ich hatte das gleiche Problem und das ist was ich getan habe

  • Entferne alle meine Edelsteine ​​mit gem uninstall gemname
  • Bundler mit installieren sudo apt-get install bundler
  • Erstelle ein Gemfile wie zuvor @Remy gesagt hat. Hier ist ein Erste Schritte mit Bundler Guide
  • Und schlussendlich bundle install

Danach erstellt Bundler ein Gemfile.lock, in dem alle benötigten Edelsteine ​​und ihre Versionen angegeben sind, damit du sie sicher verwenden kannst.


0
2018-05-14 12:02



https://teamtreehouse.com/forum/cant-make-susy-211-working

Benutzer: Iago Wandalsen Prates

Edelstein Kompass deinstallieren

Edelstein deinstallieren Sass

Edelstein deinstallieren susy

Juwel installieren susy

Juwel installiere Kompass --pre


0
2017-08-02 02:14