Frage Node.js / Windows-Fehler: ENOENT, stat 'C: \ Benutzer \ RT \ AppData \ Roaming \ npm'


Ich habe Windows 7 32-Bit. Ich habe das Neueste installiert Node.js 32 Bit. Wenn ich versuche, den Befehl auszuführen npm install jqueryIch erhalte den Fehler:

Fehler: ENOENT, stat 'C: \ Benutzer \ RT \ AppData \ Roaming \ npm

Wie löst man es?


953
2017-08-02 08:45


Ursprung


Antworten:


Das manuelle Erstellen eines Ordners namens 'npm' im angezeigten Pfad behebt das Problem.

Weitere Informationen finden Sie unter Fehlersuche Seite


1791
2017-08-02 13:04



Ich habe das gleiche Problem bei der Installation eines Pakets über npm festgestellt.

Nach dem Erstellen der npm Ordner manuell in C:\Users\UserName\AppData\Roaming\ Dieser bestimmte Fehler ist weg, aber es gab ähnliche mehrfache Fehler, als er versuchte, zusätzliche Verzeichnisse in der npm Ordner und fehlgeschlagen. Das Problem wurde nachher behoben Ausführen der Eingabeaufforderung als Administrator.


104
2017-09-09 10:15



Dies kann auch durch manuelle Installation eines Knotenpakets behoben werden.

npm install npm -g

Dadurch werden alle erforderlichen Verzeichnisse eingerichtet.


87
2017-12-15 22:55



Ich empfehle, einen alternativen Speicherort für Ihre npm-Module festzulegen.

npm config set prefix C:\Dev\npm-repository\npm --global 
npm config set cache C:\Dev\npm-repository\npm-cache --global  

Natürlich können Sie den Standort auf den jeweils am besten geeigneten Standort einstellen.

Das hat für mich gut funktioniert und alle Probleme mit Berechtigungen, die auftreten können, umgehen.


8
2018-06-09 03:39



Du kannst zu dem ... gehen Startmenü und suchen Sie das Node.js-Symbol und öffnen Sie die Shell und installieren Sie dann alles mit

install <packagename> -g

2
2017-12-29 22:33



Installieren Sie eine stabile Version anstelle der neuesten, ich habe meine Version auf Downgrade node-v0.10.29-x86.msi von 'node-v0.10.33-x86.msi' und es funktioniert gut für mich!

http://blog.nodejs.org/2014/06/16/node-v0-10-29-stable/


0
2017-12-11 10:50



Ich brauchte ein Paket von Github, das in typscript geschrieben wurde. Ich habe die neueste Version aus dem Master-Zweig in die Wurzel meines Hauptprojekts kopiert. Ich ging dann in das Verzeichnis und machte eine npm-Installation, damit die Schluckbefehle funktionierten, die ES5-Module erzeugen. Wie auch immer, um es kurz zu machen, mein Build-Prozess hat versucht, Dateien aus diesem neuen Ordner zu erstellen, also musste ich ihn aus meinem Root verschieben. Dies verursachte dieselben Fehler.


0
2017-08-02 02:25