Frage Es konnte keine geeignete Version für eckig gefunden werden


Ich bekomme diesen Fehler immer wieder. Irgendwelche Ideen warum?

$ bower install ng-roundabout --save
bower cached        git://github.com/angular/bower-angular-mocks.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular-mocks.
git#>=1.2.*
bower cached        git://github.com/Wildhoney/ngRoundabout.git#0.2.5
bower validate      0.2.5 against git://github.com/Wildhoney/ngRoundabout.git#*
bower cached        git://github.com/angular/bower-angular-mocks.git#1.2.28
bower validate      1.2.28 against git://github.com/angular/bower-angular-mocks.
git#~1.2.24
bower cached        git://github.com/angular/bower-angular.git#1.2.28
bower validate      1.2.28 against git://github.com/angular/bower-angular.git#~1
.2.24
bower cached        git://github.com/angular/bower-angular.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular.git#>=
1.2.0
bower cached        git://github.com/angular/bower-angular.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular.git#>=
1.2.*
bower cached        git://github.com/angular/bower-angular.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular.git#>=
1
bower cached        git://github.com/angular/bower-angular.git#1.2.28
bower validate      1.2.28 against git://github.com/angular/bower-angular.git#1.
2.28
bower cached        git://github.com/angular/bower-angular.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular.git#>=
 1.0.8
bower cached        git://github.com/angular/bower-angular.git#1.3.15
bower validate      1.3.15 against git://github.com/angular/bower-angular.git#~1


Unable to find a suitable version for angular, please choose one:
    1) angular#~1.2.24 which resolved to 1.2.28 and is required by ng-roundabout
#0.2.5
    2) angular#1.2.28 which resolved to 1.2.28 and is required by angular-mocks#
1.2.28
    3) angular#1.3.15 which resolved to 1.3.15 and is required by angular-animat
e#1.3.15, angular-cookies#1.3.15, angular-mocks#1.3.15, angular-resource#1.3.15,
 angular-sanitize#1.3.15, angular-scenario#1.3.15, angular-touch#1.3.15
    4) angular#>=1.2.0 which resolved to 1.3.15 and is required by angular-googl
e-maps#2.1.0
    5) angular#>=1.2.* which resolved to 1.3.15 and is required by AutoPrivilege

    6) angular#>=1 which resolved to 1.3.15 and is required by angular-bootstrap
#0.11.2
    7) angular#>= 1.0.8 which resolved to 1.3.15 and is required by angular-ui-r
outer#0.2.14
    8) angular#~1 which resolved to 1.3.15 and is required by ng-table#0.5.4

Prefix the choice with ! to persist it to bower.json

? Answer:

bower.json:

{
  "name": "xxxxxxx",
  "version": "1.0.0",
  "dependencies": {
    "angular": ">=1.2.*",
    "json3": "~3.3.1",
    "es5-shim": "~3.0.1",
    "jquery": "~1.11.0",
    "bootstrap": "~3.1.1",
    "angular-resource": ">=1.2.*",
    "angular-cookies": ">=1.2.*",
    "angular-sanitize": ">=1.2.*",
    "angular-bootstrap": "~0.11.0",
    "font-awesome": ">=4.1.0",
    "lodash": "~2.4.1",
    "angular-ui-router": "~0.2.10",
    "angular-google-maps": "~2.1.0",
    "angular-animate": "~1.3.15",
    "ng-table": "~0.5.4",
    "angular-touch": "~1.3.15"
  },
  "devDependencies": {
    "angular-mocks": ">=1.2.*",
    "angular-scenario": ">=1.2.*"
  }
}

6
2018-05-19 13:22


Ursprung


Antworten:


Einige Ihrer Abhängigkeiten erklärten ausführlich die Abhängigkeit von einer bestimmten Version von angular. In den meisten Fällen können Sie eine höhere Version ohne Auswirkungen verwenden.

hinzufügen

"resolutions"    : {
    "angular"  : "1.3.15",
  }

zu Ihrer Bower-Datei, um die angulare Version zu erzwingen

Außerdem sollten Sie die eckigen Versionen Ihrer Bower-Datei aufräumen. Sie fragen nach ng-animate 1.3.15+ und angular 1.2+. Alle eckige Modulversion sollte der Einfachheit halber gleich sein.


15
2018-05-19 13:25