Frage Lokale Wordpress-Installation zeigt nur Startseite, alle anderen Seiten nicht gefunden


Ich arbeite an einer lokalen Installation einer Live-Wordpress-Website, alle Links von der Hauptseite zeigen Not Found Fehler. Alle .htaccess-Dateien sind alle vorhanden.

Das Problem ist, dass jede Seite außer der Homepage einen Not Found-Fehler zeigt, ich kann keine Probleme mit Berechtigungen oder irgendetwas anderes finden, das dazu führen würde, dass es nicht funktioniert.

Gibt es etwas, das ich versuchen kann, das ich übersehen könnte? Ich entschuldige mich für die Vauge-Fragen, aber ich habe Schwierigkeiten herauszufinden, wo ich anfangen soll.


46
2017-07-12 19:24


Ursprung


Antworten:


Loggen Sie sich in das Admin-Panel ein (localhost / sitedirectory / wp-admin) und gehen Sie zu Einstellungen-> Permalinks und klicke Änderungen speichern. Permalinks müssen oft neu erstellt werden, nachdem eine Site gespiegelt und die Site-URL aktualisiert wurde. Sie müssen keine Einstellungen ändern, drücken Sie einfach auf Speichern und die Permalinks mit den ausgewählten Optionen werden wiederhergestellt.

Stellen Sie auch sicher das Apache Modul mod_rewrite ist auf Ihrem lokalen Stack aktiviert. IIRC WAMP (und möglicherweise XAMPP) aktivieren dies standardmäßig nicht. Dies in WAMP zu tun ist so einfach wie das Klicken auf das WAMP-Symbol in der Taskleiste, dann gehen Sie zu Apache -> Apache-Module -> mod_rewrite (klicken Sie auf um) und starten Sie dann alle Dienste neu.

Auch ich gehe davon aus, dass Sie bereits die Site und die Home - URLs aktualisiert haben (entweder in der wp_options Datenbanktabelle oder in wp-config.php). Als Referenz gibt es eine Codex-Seite dazu: Wordpress verschieben


86
2017-07-12 20:22



Sie können es auf eine sehr einfache Art und Weise tun. Geh einfach zu

Settings >> Permalinks >> und klicken Sie auf "Änderungen speichern", ohne etwas zu ändern.

Wenn Sie ein .htaccess-Dateiberechtigungs-Problem haben, müssen Sie die Berechtigung Ihres ROOT-Ordners (in dem Ihr wp-content-Ordner liegt) zum Lesen und Schreiben festlegen.

Und wieder zu gehen

Settings >> Permalinks >> und klicken Sie auf "Änderungen speichern", ohne etwas zu ändern.

Das ist alles. Hoffe es löst das Problem.


18
2017-12-23 21:38



Bitte aktivieren rewrite_module. Um es unter Windows zu aktivieren wamp folge diesen klick auf wamp -> Apache ->Apache Module -> check rewrite_module


8
2017-07-27 09:05



Apache -> Apache modules -> rewrite_module und stellen Sie sicher, dass dies angekreuzt ist. Speichern Sie dann die Änderungen in Permalinks.


2
2018-03-22 05:04



Eine andere Sache ist, dass Sie möglicherweise Ihre .htaccess ändern müssen. Zum Beispiel habe ich meine Site lokal gespiegelt, aber in einem Unterordner musste ich meine .htaccess ändern, aber Wordpress gibt Ihnen den Code, den Sie brauchen:

Einstellungen -> Permalinks -> Siehe unten auf der Seite.

Wie auch immer, der mitgelieferte Code benötigt mod_rewrite richtig funktionieren, also kombiniere diese Antwort mit der vorherigen;)


2
2017-07-04 07:55



Ich dachte, ich würde nur hinzufügen, da ich das gleiche Problem hatte, aber ich konnte nicht auf wp-admin zugreifen, um die Aktualisierung auf den Permalink vorzunehmen.

Achten Sie darauf, Ihre Datenbank unter wp_options zu bearbeiten, damit die Siteurl Ihren lokalen Host spiegelt. Ich fand tatsächlich, dass, obwohl ich das tat, es mein Problem nicht gelöst hat, so habe ich die folgenden Zeilen in der wp-config-Datei platziert:

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

Sobald ich diese Zeilen hinzugefügt hatte, konnte ich mich über wp-admin oder wp-login.php einloggen und die Permalinks wie in der Antwort beschrieben aktualisieren.


0
2017-08-01 02:17