Frage @Override ist nicht zulässig, wenn die Schnittstellenmethode implementiert wird


Ich habe das Problem im Titel erwähnt. Man könnte sagen, dass dieser Thread einen anderen dupliziert: Wie deaktiviere ich die Fehlerüberprüfung für Anmerkungen in IntelliJ IDEA?

Aber die dort gegebene Lösung funktioniert nicht. Sie sagen, dass ich folgende Maßnahmen ergreifen muss:

In der Projektstruktur | Projektdialog, ändern Sie die Projektsprachenebene auf 6.0 - @Override in den Schnittstellen.

Der Projektsprachen-Level ist momentan 6.0, aber ich sehe immer noch den Fehler.

Vic, hier ist das Fenster und es gibt keine JVM Version direkt unter Sprachlevel (leider kann ich keine Bilder posten, da ich 10 Reputation habe)


69
2018-03-14 06:27


Ursprung


Antworten:


Wenn Ihr Projekt über mehrere Module verfügt, überprüfen Sie außerdem, ob jedes Modul die Sprachstufe 6 oder höher verwendet, oder verwenden Sie das Sprachniveau des Projekts (siehe Project Settings > Modules > xxx > Language level).

Möglicherweise müssen Sie Ihr Projekt nach der Änderung erneut laden.


104
2018-03-14 09:06



Klicken Sie mit der rechten Maustaste auf Ihr Modul / Projekt, um das Kontextmenü zu sehen:

enter image description here

Wählen Open Module Settings oder drücken Sie F4. In Einstellungsfenstern:

enter image description here
Setze Wert für Choose Language level Sektion.


Sie sollten auch überprüfen Project language level auf diese Weise: drücken Strg+Alt+Verschiebung+S

enter image description here


43
2017-07-12 06:07



Eine einfachere Lösung - Inline

  1. Setzen Sie den Caret auf die @Override word und verschiebe den Caret auf der linken Seite, bis das rote Glühbirnensymbol erscheint. Dann klicke darauf.

    enter image description here

  2. Klicke auf Setzen Sie den Sprachlevel auf 6 - Override in den Schnittstellen

    enter image description here


Die obige Methode ist ein Alternative zu dem folgenden Ansatz:

  1. Gehe zu Datei> Projektstruktur ... oder drücken Sie Strg+Alt+Verschiebung+S

    enter image description here

  2. Gehe zu Projekteinstellungen> Module> Quellen> Sprachlevel und wählen Sie eine Stufe, die 6 oder größer als 6 ist.

    enter image description here


20
2017-10-21 12:55



Wenn Sie Maven verwenden, fügen Sie Maven-Compiler-Plugin zur pom.xml-Datei des Projekts hinzu.

<build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.1</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                </configuration>
            </plugin>
        </plugins>
    </build>

Das hat das Problem für mich gelöst.


10
2018-01-17 02:22



Es gibt auch ein Sprachlevel für jedes Modul. Bitte überprüfen Sie Ihre Moduleinstellungen in der Projektstruktur.


3
2018-03-14 07:41