Frage Konfigurationsfehler: Dieser Konfigurationsabschnitt kann in diesem Pfad nicht verwendet werden


Ich habe einen Fehler beim Bereitstellen einer Site auf einem Server festgestellt. Wenn ich versuche, die Homepage zu laden oder auf die Authentifizierung der neuen Site in IIS zuzugreifen, erhalte ich den Fehler:

Konfigurationsfehler: Dieser Konfigurationsabschnitt kann in diesem Pfad nicht verwendet werden.   Dies geschieht, wenn der Abschnitt auf einer übergeordneten Ebene gesperrt ist. Sperren ist   Entweder standardmäßig (overrideModeDefault = "Deny") oder explizit durch a gesetzt   Location-Tag mit overrideMode = "Verweigern" oder dem Vermächtnis   allowOverride = "false".

Mehr Details finden Sie hier, in Szenario 7 entspricht meinem Hex-Fehlercode.

Die auf der verlinkten Seite angegebene Lösung soll eingestellt werden ermöglichen für overrideModeDefault in dem Abschnitt in meinem Fehler erwähnt, in der applicationHost.config Datei. In meinem Fall, unter Sicherheit im system.webServer. Aber wenn ich mir die applicationHost.config Auf meinem lokalen Computer, auf dem die Website bereits ordnungsgemäß bereitgestellt wurde, ist dieser Abschnitt auf Verweigern.

Wenn diese Lösung korrekt ist, wie läuft meine lokale Instanz gut mit dem gleichen? web.config? Nach meinem applicationHost.configDieser Bereich sollte gesperrt sein, ist es aber nicht. Ich würde es vorziehen, das nicht zu ändern applicationHost.config Datei, weil auf diesem Server viele andere Seiten laufen. Gibt es eine andere Lösung?


1442
2018-03-20 21:07


Ursprung


Antworten:


Ich hatte das gleiche Problem. Erinnere dich nicht, wo ich es im Internet gefunden habe, aber hier ist, was ich getan habe:

  • Klicken Sie auf "Start-Schaltfläche"
  • Geben Sie im Suchfeld "Windows-Funktionen aktivieren oder deaktivieren" ein.
  • Klicken Sie im Featurefenster auf "Internetinformationsdienste".
  • Klicken Sie auf "World Wide Web Services"
  • Klicken Sie auf "Anwendungsentwicklungsfunktionen"
  • Überprüfen (aktivieren) Sie die Funktionen. Ich habe alles außer CGI überprüft.

Übrigens, ich benutze Windows 7.


2759
2017-10-12 22:06



Du könntest auch die IIS-Manager um diese Einstellungen zu bearbeiten.

Sorge dafür Erfahren Sie IIS Artikel:

Verwendung der Feature Delegation aus der Wurzel von IIS:

Feature delegation icon in IIS Manager

Sie können dann jede Lese- / Schreibberechtigungen auf Maschinenebene steuern, die Ihnen ansonsten die Berechtigung geben overrideMode = "Verweigern" Fehler.

Example use of Feature Delegation


302
2017-09-09 21:28



Zum Windows Server 2012 und IIS 8, das Verfahren ist ähnlich.

Das Web Server (IIS) und Application Server sollte installiert sein, und Sie sollten auch das optionale haben Web Server (IIS) Support unter Application Server.

Windows Server 2012 and IIS 8 Requirements for MVC


165
2018-01-30 01:01



Navigieren Sie zu "C: \ Windows \ System32 \ inetsrv \ config" (Sie benötigen hier Administratorrechte) Öffnen Sie applicationHost.config

Hinweis: In IISExpress und Visual Studio 2015 ist die Datei applicationHost.config gespeichert $(solutionDir).vs\config\applicationhost.config 

Suchen Sie den Abschnitt, der im Abschnitt "config source" der Fehlerseite angezeigt wurde. Für mich war das typischerweise "Module" oder "Handler"

Ändere das overrideModeDefault Attribut zu sein Allow

Die ganze Linie sieht nun so aus:

<section name="modules" allowDefinition="MachineToApplication" overrideModeDefault="Allow" />

Nach dem Speichern der Datei wurde die Seite in meinem Browser geladen.

Warnung: Bearbeiten von applicationHost.config unter 64-Bit-Windows


110
2018-04-30 20:22



Sie müssen Handler entsperren. Dies kann mit folgendem Befehl ausgeführt werden:

%windir%\system32\inetsrv\appcmd.exe unlock config -section:system.webServer/handlers

Vielleicht eine andere Information für Leute, die diesen Fehler auf IIS 8 bekommen, war in meinem Fall auf Microsoft Server 2012 Plattform. Ich hatte einige Stunden damit verbracht, mit anderen Fehlern zu kämpfen, die nach der Ausführung von appcmd aufkamen. Am Ende konnte ich es beheben, indem ich die Web Server Role entfernte und neu installierte.


58
2017-12-06 21:17



Nach meine Antwort auf dieses ähnliche Problem;

Versuchen Sie, die relevanten IIS-Konfigurationseinstellungen auf Serverebene wie folgt freizugeben:

  1. Öffnen IIS-Manager
  2. Wählen Sie den Server aus im Bereich Verbindungen
  3. Öffnen Konfigurationseditor im Hauptbereich
  4. Wählen Sie in der Dropdown-Liste Abschnitte den zu entsperrenden Abschnitt aus, z. system.webServer> Standardpfad
  5. Klicken Entsperren Attribut im rechten Bereich
  6. Wiederholen Sie diesen Vorgang für alle anderen Einstellungen, die Sie entsperren müssen
  7. IIS neu starten (optional) - Wählen Sie den Server im Bereich Verbindungen aus und klicken Sie im Bereich Aktionen auf Neu starten

27
2017-09-06 08:16



Ich musste diese beiden Befehle von der erhöhten Eingabeaufforderung ausführen:

%windir%/system32/inetsrv/appcmd unlock config /section:anonymousAuthentication

%windir%/system32/inetsrv/appcmd unlock config -section:windowsAuthentication

24
2017-11-18 11:22



Auf Windows Server 2012 mit IIS 8 Ich habe das gelöst, indem ich aktiviert habe ASP.NET 4.5 Feature:

enter image description here

und dann folgt Ken's Antwort.


23
2018-02-10 17:56



Für 10 gewinnen (Wahrscheinlich wird auch an anderen Windows-Versionen funktionieren.)

1. Öffnen "Schalte Windows Funktionen ein oder aus"by: WinKey + R =>" optionale Funktionen "=> OK

enter image description here

  1. Aktivieren Sie diese Funktionen unter "Anwendungsentwicklungsfunktionen "

enter image description here


21
2018-02-23 09:40



Die beste Option ist das Ändern Application Settings von dem Custom Site Delegation
Öffnen IIS und von der Wurzel wählen Feature Delegation und dann auswählen Application Settings und aus der rechten Seitenleiste auswählen Read/Write Step #1 Step #2


12
2017-08-16 12:46



Es scheint, dass es bei IIS Express und VS 2015 eine Kopie der Datei applicationHost.config unter $ (solutionDir) .vs \ config \ applicationhost.config gibt, so dass Sie dort Änderungen vornehmen müssen. Siehe diesen Link: http://digitaldrummerj.me/iis-express-windows-authentication/

Stellen Sie sicher, dass diese Zeilen wie folgt geändert werden:

<section name="windowsAuthentication" overrideModeDefault="Allow" />
<section name="anonymousAuthentication" overrideModeDefault="Allow" />
<add name="WindowsAuthenticationModule" lockItem="false" />
<add name="AnonymousAuthenticationModule" lockItem="false" />

11
2018-01-12 18:31