Frage WordPress gibt mir 404 Seite nicht für alle Seiten außer der Homepage gefunden


Plötzlich gehe ich auf meine WordPress-Website und alle Seiten geben mir eine 404 Seite nicht gefunden Seite. Ich nehme an, das Problem liegt in der Permalink-Struktur, die ich schwören konnte, dass ich sie nicht berührte. Die Permalink Einstellung ist auf "Monat und Name".

Ich habe ähnliche Fälle dieses Problems online recherchiert und viel davon hat mit dem zu tun .htaccess Datei? Ich habe es versucht, aber ich kann nicht. Vielleicht wurde es irgendwie gelöscht? Wo soll es liegen?

Irgendwelche Vorschläge werden hilfreich sein

und natürlich kann ich versteckte Dateien sehen.


75
2018-03-03 15:07


Ursprung


Antworten:


.htaccess ist eine versteckte Datei, daher müssen Sie alle Dateien so einstellen, dass sie in Ihrem ftp sichtbar sind.

Ich schlage vor, dass Sie Ihre Permalink-Struktur auf Standard (? P = ID) zurückgeben, so dass Sie sicherstellen, dass. Htaccess das Problem ist.

Danach können Sie einfach die Struktur "Monat und Name" erneut festlegen und prüfen, ob sie funktioniert.

PS: Haben Sie ein Upgrade auf 3.1 durchgeführt? Ich habe in diesem Fall einige Leute mit Plugin-Problemen gesehen.


74
2018-03-03 15:18



Dieses Problem zu beheben ist sehr einfach, wenn Sie andere Permalinks als die verwenden default sowie Day and name, Month and name, Numeric, Post name oder Custom StructureDu musst nur

Loggen Sie sich in Ihren Admin-Bereich ein: Settings > Permalinks was sollte sein: http://yoursite.com/wp-admin/options-permalink.php 

Wählen Default Permalink-Einstellung, dann speichern Sie die Änderungen

Dann kannst du Bringe es wieder zu deiner anderen vorherigen Permalink-Wahl zurück oder behalte es als default wie du willst

Beachten Sie, dass dieses Problem auftreten kann, wenn Sie Ihre Site von einer Domäne oder einem Standort zu einer anderen verschieben.


34
2017-09-27 19:59



Grundsätzlich sollte die .htaccess Datei existieren und die httpd.conf sollte korrekt sein.

In meinem Fall habe ich die Datei /etc/httpd/conf/httpd.conf im Abschnitt geändert:

<Directory "/var/www/html">

Zeile geändert ist:

AllowOverride None

zu

AllowOverride All

Und starten Sie den Webserver neu.


25
2017-09-09 04:52



Wenn das Standardverhalten (example.com/?p=42) funktioniert, sollten Sie:

  • Wechseln Sie zu Ihrem bevorzugten Permalink-Stil: Admin: Settings > Paramalinksund klicken Sie auf Speichern. Manchmal behebt es das Problem. Wenn es nicht geschah:
  • Überprüfen Sie, dass die Datei /path/to/wordpress/.htaccess wurde geändert und enthält nun die Zeile RewriteEngine On. Wenn es nicht ist, ist es Wordpress Erlaubnisproblem.
  • Stellen Sie sicher, dass das 'rewrite' Modul geladen ist: Erstellen Sie eine PHP Datei mit

    <?php
      phpinfo()
    ?>
    

    Öffnen Sie es im Browser und suchen Sie nach mod_rewrite. Es sollte im Abschnitt "Geladene Module" sein. Wenn es nicht ist, aktivieren Sie es - Sehen Sie sich Ihren Apache-Standard an index.html Datei für Details - in Ubuntu machen Sie es mit dem Helfer a2enmod.

  • Vergewissern Sie sich, dass der Apache - Server auf die .htaccess Datei. öffnen httpd.conf - oder es ist Ubuntus Alternative, /etc/apache2/apache2.conf. Darin solltest du etwas haben wie

    <Directory /path/to/wordpress>
      Options Indexes FollowSymLinks
      AllowOverride All
      Require all granted
    </Directory>
    
  • Vergessen Sie nicht, Ihren Apache-Server neu zu starten, nachdem Sie diese Änderungen vorgenommen haben. sudo service apache2 restart


12
2018-01-30 02:06



Innerhalb der WordPress Admin-Oberfläche machen Sie folgendes:

  1. Gehe zur Admin-Einstellung

  2. Klicken Sie auf Permalink und wählen Sie den Post-Namen im Radio-Button.

  3. Scrolle nach unten und du wirst sehen .htaccess Code hier wie.

    <IfModule mod_rewrite.c>
        RewriteRule ^index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /wordpress/index.php [L]
    </IfModule> 
    
  4. Kopieren Sie den Code und fügen Sie ihn ein .htaccess Datei.

10
2018-03-14 10:24



Es ist einfach, das Problem zu beheben, indem Sie einfach die folgenden Schritte ausführen , Wenn Sie Zugang zu Ihrem Admin-Dashboard dann einfach anmelden

Go to Settings » Permalinks, and simply click on Save Changes button.

enter image description here

Dadurch werden Ihre Permalinks-Einstellungen aktualisiert und die Umschreibregeln gelöscht. In den meisten Fällen behebt diese Lösung den WordPress Posts 404 Fehler. Wenn es jedoch nicht für Sie funktioniert, müssen Sie Ihre .htaccess-Datei wahrscheinlich manuell aktualisieren.

Melden Sie sich mit FTP bei Ihrem Server an und ändern Sie die .htaccess Datei, die sich am selben Ort befindet, an dem sich Ordner wie / wp-content / und / wp-includes / befinden, Setze einfach die unten stehenden Codes in deinen .htaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Hoffe, das wird das Problem lösen.


9
2017-11-30 05:10



Dieser Fehler verursacht aufgrund der Deaktivierung von Rewrite Mod in Apache httpd.conf Dokument, kommentieren Sie einfach und genießen Sie die Seo freundliche Permalinks


6
2018-04-05 22:34