Frage Gradle gibt einen Fehler aus "Konnte Plug-in vom Typ 'AppPlugin' nicht erstellen"


Ich versuche, ein einfaches Android-Projekt mit Gradle zu erstellen. Ich arbeite in einem Computer mit Debian GNU / Linux 7 'Wheezy'.

Ich folgte den Empfehlungen in Gradle Plugin Benutzerhandbuch - Android Tools Projektseite, aber es wird ein Fehler ausgegeben:

FAILURE: Build failed with an exception.

* Where:
Build file '/home/alex/Proyectos/MyLogin/build.gradle' line: 11

* What went wrong:
A problem occurred evaluating root project 'MyLogin'.
> Could not create plugin of type 'AppPlugin'.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 4.817 secs

Ich folgte den Spezifikationen:

  • Gradel 1.9
  • Plugin 0.7
  • SDK 17+ (eigentlich 19)

Ich habe auch ein neues Projekt begonnen, und die Ergebnisse, die ich zeigte, wurden vom Kommando ausgegeben gradle tasks wie in der Dokumentation gezeigt.

Ich habe auch versucht, 1.10, aber das Ergebnis ist das gleiche.

Sogar diese Frage war nicht nützlich, da es mit "upgrade" auf Grad 1,6 gelöst wurde (ich verstehe, dass Plugin 0.7 mindestens 1.9 erfordert).

Ich habe das versucht, nachdem ich mit demselben Fehler versagt habe Android-Studio und IntelliJ Idee.

BEARBEITEN: Ich habe auch mit neuen Projekten in beiden IDEs versucht und das gleiche Problem bekommen. Aber was mich am meisten überrascht, ist, dass beide IDEs Grad 1.8 in ihrer verpackten Form verwenden. Ich habe versucht, beide zu kitzeln, um meine lokale Installation zu verwenden, aber immer noch das gleiche Problem.

Was mache ich falsch? Ist es ein Fehler? Wie kann ich das Problem vermeiden?

Bitte hilf mir.

BEARBEITEN: Hier ist mein build.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.7.+'
    }
}

apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 14
    buildToolsVersion '19.0.1'

    defaultConfig {
        minSdkVersion 14
        targetSdkVersion 19
    }
}

sourceCompatibility = 1.6

version = '0.1'

dependencies {
    compile 'com.android.support:support-v4:18.0.0'
    //compile project(':core')
}

76
2017-12-28 05:53


Ursprung


Antworten:


Google hat sich mit Version 0.7.2 des Gradle Plugin:

Hinweis: 0.7.2 erfordert Java7. Das ist ein Fehler. Verwenden Sie stattdessen 0.7.3.

Release 0.7.3 aktiviert die Java6-Unterstützung erneut. Gradle 0.7.3 in meinen Build-Dateien zu deklarieren löst das für mich.

Niemand ist perfekt :)

http://tools.android.com/tech-docs/new-build-system


27
2018-01-08 02:22



Verwenden Sie Gradle 1.9 statt Gradel 1.10. Es gibt ein Problem mit 1.10: https://code.google.com/p/android/issues/detail?id=63822

Auch hier beantwortet:

Org.gradle.api.artifacts.result.ResolvedModuleVersionResult kann nicht gefunden werden, wenn das Android-Plug-in in Gradle angewendet wird


22
2017-12-28 18:14



Ich habe es mit Gradle 1.10 mit dem Gradle Plugin 0.8.0 funktioniert.

// /build.gradle
// Top-level build file where you can add configuration 
// options common to all sub-projects/modules.
buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.8.+'
    }
}

...

# /gradle/wrapper/gradle-wrapper.properties.
#Sat Feb 01 20:41:29 CET 2014
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-bin.zip

19
2018-02-01 21:26



Wenn Sie das Projekt mit der Befehlszeile wie folgt erstellen:

android create project -g -v 1.2.2 --target 1 --name rtest --path rtest --activity MainActivity --package com.mydomain.rtest

Das Projekt wurde erstellt, um die Version 1.2.2 des android-gradle-plugins zu verwenden, aber das Projekt wird mit grddle 1.12 initialisiert ist nicht kompatibel.

Um es zu beheben, machen Sie Folgendes:

  1. Öffnen rtest/gradle/wrapper/gradle-wrapper.properties und einstellen distributionUrl zu der Freigabe, die du willst; beispielsweise: http\://services.gradle.org/distributions/gradle-2.2.1-all.zip (Vergiss nicht, dem Doppelpunkt zu entkommen - ja, das bringt mich auch zum Lächeln);
  2. Öffnen build.gradle und ändern runProguard false zu minifyEnabled false;
  3. ./gradlew clean && ./gradlew assembleDebug
  4. Ich entferne auch das Verborgene .gradle Ordner, aber ich bin mir nicht sicher, ob es notwendig ist

Und alles funktioniert wieder.


6
2018-06-10 13:06



Wenn Sie versuchen, Ihr Gradle 1.9-Projekt mit Gradle 1.10 zu aktualisieren

task wrapper(type: Wrapper) {
    gradleVersion = '1.10'
}

und Befehl ./gradlew wrapper Sie erhalten den gleichen Fehler wie oben.

Die Lösung besteht darin, Gradle 1.10 auf Ihrem Computer zu installieren und Ihr Projekt zu aktualisieren den Wrapper nicht verwenden

gradle wrapper


1
2018-01-24 09:30



Sie können diesen Fehler auch erhalten, wenn Sie Ihr System aktualisieren und vergessen, das Android Studio zu aktualisieren.


1
2018-03-07 04:16



Ersetzen Sie den Klassenpfad 'com.android.tools.build:gradle:2.1.0-rc1' durch den Klassenpfad 'com.android.tools.build:gradle:2.1.0', falls Sie die Version 2.1 von studio verwenden. Das hat mein Problem gelöst.


1
2017-07-29 07:28



Ich habe das heute bei der Ausführung von Degrees. Ich hatte den Ubuntu-Standard von Gradle-1.4 installiert. Dies hat nicht funktioniert, also habe ich das neueste Gerät - 1.12 ausprobiert und habe das gleiche Problem.

Das Herunterladen und Verwenden von Gradle-1.10 (und das Anpassen meiner Datei "gadle-wrapper.properties" an diese Version) behob das Problem.

Dies ist mit Android Studio 0.5.8.


0
2018-05-27 22:05



Gehe zu den Abhängigkeiten und ändere einfach den Abhängigkeiten Klassenpfad zu  Klassenpfad 'com.android.tools.build:gradle:2.0.0-beta6' Rest Gradle wird dafür sorgen. Viel Spaß beim Programmieren :)


0
2018-03-17 05:14