Frage WCF-Bindung nicht gefunden Fehler?


Ich verwende VSTS 2008 + C # + .Net 3.0. Ich verwende selbst gehosteten WCF. Beim Ausführen der folgenden Anweisung gibt es den folgenden Fehler, der nicht gefunden wurde. Ich habe meine ganze app.config-Datei gepostet, irgendwelche Ideen, was ist falsch?

ServiceHost host = new ServiceHost(typeof(MyWCFService));

Fehlermeldung,

Configuration binding extension 'system.serviceModel/bindings/MyBinding' could not be found. Verify that this binding extension is properly registered in system.serviceModel/extensions/bindingExtensions and that it is spelled correctly.

Vollständige app.config,

<?xml version="1.0"?>
<configuration>
  <system.serviceModel>
    <bindings>
      <wsHttpBinding>
        <binding name="MyBinding"
            closeTimeout="00:00:10"
            openTimeout="00:00:20"
            receiveTimeout="00:00:30"
            sendTimeout="00:00:40"
            bypassProxyOnLocal="false"
            transactionFlow="false"
            hostNameComparisonMode="WeakWildcard"
            maxReceivedMessageSize="100000000"
            messageEncoding="Mtom"
            proxyAddress="http://foo/bar"
            textEncoding="utf-16"
            useDefaultWebProxy="false">
          <reliableSession ordered="false"
               inactivityTimeout="00:02:00"
               enabled="true" />
          <security mode="Transport">
            <transport clientCredentialType="Digest"
               proxyCredentialType="None"
               realm="someRealm" />
          </security>
        </binding>
      </wsHttpBinding>
    </bindings>
    <services>
      <service name="MyWCFService"
                behaviorConfiguration="mexServiceBehavior">
        <host>
          <baseAddresses>
            <add baseAddress="http://localhost:9090/MyService"/>
          </baseAddresses>
        </host>
        <endpoint address="" binding="MyBinding" contract="IMyService"/>
        <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange" />
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior name="mexServiceBehavior">
          <serviceMetadata httpGetEnabled="True"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
  </system.serviceModel>
<startup><supportedRuntime version="v2.0.50727"/></startup></configuration>

Danke im Voraus, George


17
2018-06-22 08:26


Ursprung


Antworten:


Sie haben missverstanden, wie Sie Bindungen konfigurieren - Ihre Bindung am Endpunkt muss ein bekanntes Protokoll sein;

 <endpoint address="" binding="wsHttpBinding" contract="IMyService"/>

Sobald Sie das haben, können Sie die Bindungskonfiguration, die Sie in den Einstellungen für dieses Protokoll definiert haben, mit dem so genannten bindingConfiguration-Element angeben

 <endpoint address="" binding="wsHttpBinding" 
  bindingConfiguration="MyBinding" contract="IMyService"/>

23
2018-06-22 08:32