Frage Fehler - Zugriff auf die IIS-Metabasis nicht möglich


Nach der Installation von Visual Studio 2012 und dem Öffnen meiner Lösung erhalte ich eine Reihe von Fehlern in dieser Form:

Das Webanwendungsprojekt Foo ist für die Verwendung von IIS konfiguriert.
  Kann nicht auf die IIS-Metabasis zugreifen. Sie sind nicht berechtigt, auf IIS-Websites auf Ihrem Computer zuzugreifen.

Ich bekomme das für jede unserer Webanwendungen. Dinge, die ich versucht habe:

  1. Visual Studio als Administrator ausführen
  2. Ausführen von aspnet_regiis.exe -ga MyUserName
  3. Ausführen von aspnet_regiis.exe -i

Dies scheinen gemeinsame Lösungen für dieses Problem zu sein, aber ich hatte keinen Erfolg mit ihnen. Kann ich noch etwas versuchen?


762
2017-10-12 13:15


Ursprung


Antworten:


Auf Windows 8 Pro:

%systemroot%\inetsrv\config

Auf Windows 7 und 8.1 und 10

%systemroot%\System32\inetsrv\config 

(Woher %systemroot% ist gewöhnlich C:\Windows)

Navigieren Sie zu dem entsprechenden Speicherort oben in Windows Explorer. Sie werden mit einem Popup gesperrt, das sagt:

"Sie haben keinen Zugriff auf diesen Ordner - Klicken Sie auf" Weiter ", um dauerhaft auf diesen Ordner zuzugreifen"

Klicken Sie für diesen Ordner auf "Fortfahren" und darunter den Ordner "Exportieren". Ich änderte die Verknüpfung zurück zu "Als mich ausführen" (ein Mitglied der Domäne und lokale Administratoren) und konnte die Lösung öffnen und bereitstellen.


1349
2017-07-04 01:58



Ich denke, Sie betreiben Visual Studio nicht mit Administratorrechten. Schau das:

http://bloggingabout.net/blogs/rick/archive/2012/10/04/unable-to-access-the-iis-metabase.aspx

Zitieren

Die Lösung dafür ist einfach: Starten Sie Ihr Visual Studio mit "Ausführen als   Administrator ". Sie können dies tun, indem Sie mit der rechten Maustaste auf die Verknüpfung und klicken   Wählen Sie "Als Administrator ausführen".


235
2017-10-12 13:19



Ich denke, wir sind bei der Arbeit auf ein ähnliches Problem gestoßen. Für uns bestand die Lösung darin, in die Systemsteuerung -> Programme und Funktionen -> Windows-Funktionen ein- oder auszuschalten ... innerhalb dieser mussten wir Internetinformationsdienste -> Webverwaltungstools -> IIS 6 Verwaltungskompatibilität -> auswählen IIS Metabase und IIS 6 Konfigurationskompatibilität. Windows Features dialog showing IIS Metabase option

Probieren Sie es aus und lassen Sie es mich wissen, wenn es hilft!

Hinweis: Wir verwenden IIS 7.5 unter Windows 7 mit Visual Studio 2005 und 2010 sowie mit Super-Old-School-Webdiensten (.asmx).


47
2017-10-12 13:39



Ich habe dieses Problem gelöst, indem ich IIS AppPool Identitätsberechtigungen für die %systemroot%\inetsrv\config


31
2018-05-05 22:06



Wenn Sie an einem Projekt arbeiten, das keine Verwendung von IIS erfordert, können Sie das Projekt mit diesem Fehler öffnen, indem Sie einfach mit der rechten Maustaste auf das entladene Projekt klicken und anschließend auf Bearbeiten klicken. Suchen Sie nach:

<ProjectExtensions>
    <VisualStudio>
      <FlavorProperties GUID="">
        <WebProjectProperties>
          <UseIIS>True</UseIIS>
        </WebProjectProperties>
      </FlavorProperties>
    </VisualStudio>
  </ProjectExtensions>
</Project>

und setze USEIIS auf false

<UseIIS>False</UseIIS>

Laden Sie das Projekt neu, indem Sie nach dem Speichern mit der rechten Maustaste darauf klicken.


25
2017-08-06 05:57



Ich hatte zwei verschiedene Arten von Problemen, die zu diesem Fehler führten, und dachte, ich würde teilen ...

1. The directory was on an network share and due to UAC restrictions, was 
   unable to be accessed -- even when running as an admin.
2. The directory was on a drive that didn't exist...

Beides ergibt sich aus einer unglücklichen (imo) Entscheidung von MS, Dinge in das Documents oder My Document Verzeichnis zu legen, kombiniert mit wirklich miserablen Fehlermeldungen. In beiden oben genannten Fällen bestand das grundlegende Problem darin, dass die IISExpress-Konfigurationsdatei geht in Eigene Dateien, und es war entweder nicht vorhanden oder konnte nicht zugegriffen werden.


18
2017-10-04 06:38



Danke an alle, die geantwortet haben. Da dies für eine lange Zeit geschlossen war, konnte ich nicht viel Feedback geben, aber ich habe mein Problem behoben. Ich habe viele dieser anderen Lösungen ausprobiert und sie haben mein Problem nicht behoben, aber ich bin mir sicher, dass sie helfen, wenn die Ursache anders ist.

Meine Lösung

Ich löste dieses Problem, indem ich die IIS- und .Net Framework-Funktionen in Windows 7 deaktivierte und sie dann wieder aktivierte. Es scheint, als ob diese Neuinstallation mein Problem behoben hat. Ich weiß immer noch nicht, was das Problem verursacht hat, aber mindestens ein anderer Entwickler in meinem Team hatte das gleiche Problem.


12
2018-02-05 19:30



Ich hatte dieses Problem - die Symptome waren die gleichen, aber das Problem, das ich hatte, war, dass ich den Ordner "Eigene Dateien" auf einer Netzwerkfreigabe festgelegt hatte und auf die Freigabe nicht zugegriffen werden konnte.

Das Grundproblem bestand darin, dass auf die IIS-Konfigurationsdateien unter% USERPROFILE% \ Documents nicht zugegriffen werden konnte. Nachdem ich den Speicherort des Ordners "Eigene Dateien" geändert habe (ich habe den Registrierungswert geändert), hat er wieder funktioniert.

Ich weiß, dass dies vielleicht kein gewöhnliches Szenario ist, dem Sie begegnen könnten, aber ich habe es hier gepostet, weil es die gleichen Symptome zeigt.


11
2018-02-15 22:15



Verwenden Sie in einem Windows 81 von einer Admin-Eingabeaufforderung aus:

icacls "C:\Windows\System32\inetsrv\config" /t /grant "IIS AppPool\DefaultAppPool":(R)

Gehen Sie dann zurück in VS, klicken Sie mit der rechten Maustaste auf das fehlerhafte Projekt und wählen Sie Neu laden.

Kredit an: Überblick über die IIS7-Berechtigungen - ApplicationPoolIdentity


10
2017-09-09 15:12



Sie könnten über dieses Problem laufen und dasselbe Problem wie ich haben. Ich habe es vorher "gelöst" und dann Stromausfall und Computer abgestürzt, nicht sicher warum a Registrierung Einstellung zurückgesetzt, aber es ist die QUELLE von meinem Problem.

  1. Ich habe alles versucht als Administrator
  2. Alle IIS / IIS Express-Installationen werden neu installiert.
  3. Diverse "Hacks"

Kam dazu zurück, die Registrierung wieder reparieren zu müssen.

  1. Konnte nicht als Administrator Regedit sogar öffnen (Notwendigkeit, auf Registrierung zuzugehen, da Problem nicht mit gpedit.msc admin Schablone ist)

  2. UnHookExec.inf auf dem Desktop

Speichern Sie einfach UnHookExec.inf und installieren Sie es, indem Sie mit der rechten Maustaste klicken und installieren auswählen. Wenn Sie die Datei installieren, wird kein Popup oder Hinweisfeld angezeigt. http://www.tweakandtrick.com/2011/04/enable-regedit-registry-editor.html

  1. HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ Benutzer Shell Ordner \ Personal verweist auf nicht vorhandene Dateifreigabe. Das Ändern auf lokalen Pfad löste dieses Problem für mich. - Pasi Savolainen 14. Juli 14 um 08:41 Uhr

(gewechselt von \\cs2data\home\stickelt\my documents  zu c:\dev  )

Jetzt Alles ist gut und Visual Studio öffnete die Lösung mit 15 Projekten und stellte eine Verbindung zu IIS her und beanstandete nicht, nicht auf die iis-Metadaten zugreifen zu können

Ich war noch nie zuvor auf dieses Problem gestoßen, da niemand dieses Problem hatte (viele waren schon lange hier, einige haben Klone von anderen Maschinen, die "funktionierten" und viele sind auf einer anderen Domain usw.)


7
2017-07-01 20:11