Frage Aptana Error-pydev: Port nicht gebunden (gefundener Port -1)?


Ich habe gerade mein Aptana Studio3 aktualisiert. Wenn ich meine Python-Datei öffne, heißt es, dass sie nicht finden kann map, range und filter und einige andere Methoden. Aber wenn ich meinen Code ausführe, läuft er ohne Probleme. Meine Code-Vervollständigung funktioniert nicht mehr. Der Fehler für die Codevervollständigung, wenn ich STRG + LEERTASTE verwende, ist

   Port not bound (found port -1). Is there an enabled firewall? 

Ich weiß nicht, wo das Problem ist? !! Ich suchte, aber ich konnte keine richtige Lösung finden. Ich benutze Windows 7.


34
2018-01-11 17:46


Ursprung


Antworten:


Es scheint, dass dies auf PyDev gelöst ist und das Problem ist, dass Sie PyDev auf Aptana 3.6.0 nicht aktualisieren können. Version 3.6.1 entfernt die Integration mit PyDev und ermöglicht es Ihnen, PyDev zu aktualisieren. Also habe ich Aptana 3.6.1 durch das Beta-Repository installiert und dann das neueste PyDev installiert.

Aptana Beta-Link zum Hinzufügen zu "Verfügbare Software-Sites" auf Aptana: http://preview.appcelerator.com/aptana/studio3/standalone/update/beta/

Upgrade auf Aptana 3.6.1. Dies deinstalliert PyDev.

PyDev-Link zum Hinzufügen zu "Verfügbare Software-Sites" auf Aptana: http://pydev.org/updates

Installiere PyDev.

Und dann wird "Port nicht gebunden" gelöst.


22
2017-09-22 09:44



Ich habe den Unterschied zwischen Aptana 3.4 und 3.5 verfolgt, einen gegabelten Prozess gefunden, um pycompletionserver an bestimmten Ports zu starten:

/usr/bin/python2.7 -u   /home/khaled/Downloads/Aptana_Studio_3/plugins/org.python.pydev_2.7.0.2013032300/pysrc/pycompletionserver.py   48914 48082

In 3.5 wird dieser Prozess überhaupt nicht gefunden, auch die Version von pydev wurde geändert.

Ich habe es geschafft, den Completion-Server mit den gleichen alten Ports zu starten, trotzdem treten Port-nicht-gebundene Fehler auf.

/usr/bin/python2.7 -u   /home/khaled/Downloads/Aptana_Studio_3/plugins/org.python.pydev_3.0.0.1388187472/pysrc/pycompletionserver.py   48914 48082 & [1] 6752

-

khaled: ~ / Downloads $ pycompletionserver startet pycompletionserver   Erstellen von Socket pycompletionserver Warten auf Verbindung auf 127.0.0.1   (48914)

Vielleicht hat Aptana die Portnummern geändert ....

Es tut mir leid, wieder auf 3.4 zurückzugreifen :-(


3
2018-01-14 11:50



Ich habe das gleiche Problem seit einiger Zeit. Ich habe ursprünglich auf die vorherige Version heruntergestuft, aber jetzt beschlossen, auf die Version 3.6.1 Beta zu aktualisieren, und dieses Problem scheint behoben zu sein. Anleitung zum Upgrade auf 3.6.1 Hier.

Der PyDev-Interpreter wird bei der Aktualisierung möglicherweise nicht automatisch installiert, sodass Sie ihn erneut manuell installieren müssen. Bei Bedarf gibt es Anweisungen Hier.


2
2017-10-14 17:59



Mit Info von idubs11 konnte ich meine Aptana 3.6.1 (download 2016-03-01) in Betrieb nehmen. Es zeigte das gleiche Problem, Port nicht gebunden. Ich konnte Pydev nicht deinstallieren, bis ...

  1. Ich fügte hinzu http://pydev.org/updates zu den Installationsorten
  2. Ich fügte hinzu http://preview.appcelerator.com/aptana/studio3/standalone/update/beta/  zu den Installationsorten
  3. Dann klickte Hilfe -> Nach Updates suchen
  4. Installierte das Update.

Jetzt war es in einem seltsamen Zustand, kein Pydev mehr und jetzt mit der Beta-Version. Ich habe dann die pydev.org-Installationswebseite benutzt, um pydev zu installieren, und jetzt funktioniert alles gut.


2
2018-03-01 18:52



Ich hatte dieses Problem, obwohl die Windows-Firewall deaktiviert war. Ich habe sogar eine saubere Neuinstallation (Version 3.6) vergeblich versucht. Am Ende musste ich auf Downgrade umsteigen Version 3.4.1. Es ist jetzt kein Problem mehr.


1
2017-09-16 02:20



Ich weiß, dass das OP um Hilfe in Bezug auf ein Windows-Betriebssystem gebeten hat, aber wenn jemand dies unter OS X 10.9+ arbeiten lassen möchte, dann folge den Schritten, die ursprünglich von vorgeschlagen wurden Daigorocub , welche sind:

  • Aptana Beta-Link zum Hinzufügen zu "Verfügbare Software-Sites" auf Aptana
  • Upgrade auf Aptana 3.6.1. Dies deinstalliert PyDev.
  • PyDev-Link zum Hinzufügen zu "Available Software Sites" auf Aptana
  • Installiere PyDev.

ABER, bei der Installation von PyDev deaktivieren Sie das Häkchen "Zeige nur die neuesten Versionen der verfügbaren Software" Kontrollkästchen in Aptana's Hilfe> Neue Software installieren Fenster und stellen Sie sicher, dass Sie die neueste Version 2.x.x von PyDev wählen.

PyDev 3.x + benötigt Java JDK 7+, um ausgeführt zu werden, aber für die neuesten Versionen von OS X ist jedes Java JDK 7+ nur als 64-Bit-Version verfügbar. Aptana Studio 3 für OS X scheint nur in 32-Bit verfügbar zu sein, was ein 32-Bit-JDK erfordert.

Eine weitere Option ist die Installation einer 64-Bit-Eclipse-IDE und die separate Installation von Aptana Studio 3.6.1 als Plugin und dem neuesten PyDev.

Hinweis:  Sie werden höchstwahrscheinlich die neueste Version von Java für OS X 2014-001 von Apple herunterladen und installieren müssen. http://support.apple.com/kb/DL1572?viewlocale=de_DE&locale=de_DE Dies wurde ursprünglich von vorgeschlagen ChancePance in seiner Antwort auf "OSX Yosemite - JVM Shared Library enthält nicht das JNI_CreateJavaVM Symbol" -Thread


1
2018-02-15 22:43



Ich habe Windows 10 ausgeführt. Ich habe dieses Problem behoben, indem ich das Installationsprogramm erneut ausgeführt und "Reparatur" ausgewählt habe. Behebung dieses Problems für mich und verlor dabei keine Konfiguration.


1
2017-12-19 12:56



Eine saubere Aptana Neuinstallation hatte dies für mich behoben.


0
2018-01-15 02:13