Frage Npm install browserify kann nicht ausgeführt werden


Ich versuche zu rennen npm install browserify sowohl lokal als auch global (-g)

aber ich habe immer die folgenden Fehler bekommen

npm ERR! peerinvalid The package bn.js does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer miller-rabin@1.1.2 wants bn.js@^0.16.0

npm ERR! System Darwin 14.0.0
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "browserify"
npm ERR! cwd /Users/kanitw/Dropbox/_Projects/_idl/_visrec/vegalite
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! code EPEERINVALID
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/kanitw/Dropbox/_Projects/_idl/_visrec/vegalite/npm-debug.log
npm ERR! not ok code 0

Nicht sicher, wie man es löst.

(Meine Knotenversion ist v0.10.24, ich bin auf OSX Yosemite)


5
2018-01-02 13:37


Ursprung


Antworten:


Um das zu machen workaround Arbeit, du musst

  1. Löschen Sie das vorhandene node_modules Mappe.
  2. npm install miller-rabin@1.1.1 --save-peer
  3. npm install browserify

Das funktioniert garantiert.


3
2018-01-02 15:38



Hatte das gleiche Problem unter Linux. Versuche zu laufen npm update -g vor der Installation von browserify. Das hat für mich funktioniert.


2
2018-01-02 15:25



Dieses Commit führte die bahnbrechende Veränderung ein: https://github.com/indutny/miller-rabin/commit/bb85f555974587a410a17173f0bc484133b53cb7

Der Autor der Bibliothek sollte es beheben, aber in der Zwischenzeit können Sie:

  1. Löschen Sie das vorhandene node_modules Mappe
  2. npm install miller-rabin@1.1.1 --save-peer
  3. npm install browserify

2
2018-01-02 13:59



Ich habe dieses Problem kürzlich auf dem Github von browserify gefunden.

https://github.com/substack/node-browserify/issues/1049

Es ist eine Problemumgehung beschrieben.


1
2018-01-02 14:36



Es gibt Details zu einer Problemumgehungsliste in den Problemen auf der GitHub-Seite

Fehler beim Auflisten

Um die im Problem gepostete Lösung zusammenzufassen, müssen Sie miller-abin@1.1.1 als Peer-Abhängigkeit in Ihrem eigenen Projekt installieren (npm install miller-rabin@1.1.1 --save-peer), das sicherstellt, dass der bn .js @ 0.15 wird anstelle der aktuelleren Version verwendet.

Ich hoffe, das hilft!


0
2018-01-02 13:58